Page 1 of 1

GN stopped opening links in external browser

Posted: Mon Nov 22, 2010 10:21 am
by fcmk
I have no idea what happened, but GN doesn't do anything at all anymore when I click the links. Opening the links inside GN does work, but it's probably faster to copy the link and paste it in Opera. Links from other programs work fine when opening them straight to Opera, which has lead me to believe that this might be a bug in GN.

Any ideas?

Re: GN stopped opening links in external browser

Posted: Mon Nov 22, 2010 4:25 pm
by ktm
If I had to guess, I'd say blame Opera (probably silently installed an update that broke stuff?). It's my favourite browser, but a real bitch to get to properly integrate with other programs. I have a wrapper script that launches it with "opera -nomail -newtab $(url)", maybe try it this way? Can't remember exactly why I put the "-newtab" in there however.

If you don't want to use a wrapper, setting ExternalBrowser in the ini file's "Advanced" section might work too, haven't tried it though, so no guarantees.

Code: Select all

[Advanced]
ExternalBrowser="path/to/opera.exe -newtab"

Re: GN stopped opening links in external browser

Posted: Mon Nov 22, 2010 4:34 pm
by fcmk
ktm wrote:If you don't want to use a wrapper, setting ExternalBrowser in the ini file's "Advanced" section might work too, haven't tried it though, so no guarantees.

Code: Select all

[Advanced]
ExternalBrowser="path/to/opera.exe -newtab"

That did it! Thank you very much.

Re: GN stopped opening links in external browser

Posted: Tue Mar 15, 2011 11:35 am
by mas912
Path must be without quotes:

Code: Select all

[Advanced]
ExternalBrowser=c:\Program Files (x86)\Opera\opera.exe


Works properly with 389.

Re: GN stopped opening links in external browser

Posted: Mon Oct 10, 2011 8:23 am
by bookofradeluxe
That did it! Thank you very much.