Page 1 of 1

1.0 Build 362

Posted: Mon Feb 13, 2006 9:36 pm
by Jack
+Added: GreatNews now supports plugins to extend BlogThis functions.
A demo plugin is included to support w.Bloggar. Source code will be released this week. It's fairly easy to support other blogging tools now.

+Added: Koren language pack (Thank you very much Moon sung-wook!)
+Added: Czech language pack (Thank you very much Tirsor!)

http://www.curiostudio.com/nightly0

Posted: Tue Feb 14, 2006 12:31 pm
by mkizer
Sweet! I like the w.Bloggar plugin...works great.

Re: 1.0 Build 362

Posted: Tue Feb 14, 2006 1:34 pm
by tamsun
GreatNews wrote:+Added: GreatNews now supports plugins to extend BlogThis functions.
A demo plugin is included to support w.Bloggar. Source code will be released this week. It's fairly easy to support other blogging tools now.

+Added: Koren language pack (Thank you very much Moon sung-wook!)
+Added: Czech language pack (Thank you very much Tirsor!)

http://www.curiostudio.com/nightly0


please check the build number. It's still displayed as build 361

Posted: Tue Feb 14, 2006 8:41 pm
by Jack
Thanks tamsun. I just changed it.

Posted: Wed Feb 15, 2006 1:14 pm
by Kanel
With this build I can no longer use custom mouse commands assigned for the program in IntelliPoint mouse software. :(
Any clue why that is? :?

Edit: Nevermind, now it works again! :)

Posted: Sat Feb 18, 2006 10:58 am
by jiminy
i tried to upgrade from build 360 to this one (using the executable file rather than the zip) im getting an error when it tries to update the database structure.

the dialog box says:
Data file found 1.0.0.102
button says
Upgrade to: 1.0.0.104

when i click the button i get the following error:
Data File upgrade failed: ERROR [1] table feed2 already exists.

luckily i saved the installer exe for 360, so i just re-ran that and i got build 360 running again.

Posted: Sun Feb 19, 2006 9:09 pm
by Jack
jiminy wrote:i tried to upgrade from build 360 to this one (using the executable file rather than the zip) im getting an error when it tries to update the database structure.

the dialog box says:
Data file found 1.0.0.102
button says
Upgrade to: 1.0.0.104

when i click the button i get the following error:
Data File upgrade failed: ERROR [1] table feed2 already exists.

luckily i saved the installer exe for 360, so i just re-ran that and i got build 360 running again.


wow! this is scary. What error message did you get in the first try? Thanks.

Posted: Wed Feb 22, 2006 10:51 am
by jiminy
i believe the error message was the same the first time i tried it.
i even tried deleting the feed2 table, then rerunning the installer, but that didnt work. so i restored the database back to how it was, then reran the build 360 installer.

Posted: Wed Feb 22, 2006 10:05 pm
by Jack
jiminy, can you send me your newsfeed.db file? I would like to check its layout more carefully. I'm very nervous about the error message you are getting. The db upgrade program supposes to be transaction protected. It should never cause file damage even upgrade fails. If the file is too big, can you use Tools->Cleanup to clean everything? Thanks.