Page 1 of 1

1.0 Build 359

Posted: Tue Jan 24, 2006 9:03 pm
by Jack
+Added: GreatNews now updates local copy of articles if they were changed. (Thanks Alex)
If article timestamp or title was changed, GreatNews will also set it to unread.
+Added: Article now can be configed to open in current tab, external browser, or new tab.
(Tools->Options->Usability)
+Added: News watch now can be disabled (Thanks iw)
-Fixed: Compatibility issue with http://www.baravalle.it/phpGrabComics (thanks gdusenberry)
-Fixed: Partially fixed auto detect problem with sourceforge.net (Thanks flock)
If IE engine is used , clicking sourceforge rss feeds in GreatNews will prompt to subscribe. But the feeds still won't show on statusbar.

http://www.curiostudio.com/nightly0

Note: please do not submit nightly builds to BetaNews. These builds are not as stable as public beta!

.

Posted: Wed Jan 25, 2006 1:30 am
by wormeyman
why shouldn't we submit beta's to betanews (btw i'm not the one submitting them)

+Added: GreatNews now updates local copy of articles if they were changed. (Thanks Alex)

Maybe i like to archive old stuff?

Also when scroll with my mouse it sometimes switches to the next unread page and that gets really annoying how do i turn it off or is this a known bug/feature i'm pretty sure it's a feature i just can't figure out how to turn it off.

Posted: Wed Jan 25, 2006 11:12 pm
by Jack
These nightly builds are not very stable. Sometimes only existing GreatNews users know what's wrong and can give helpful information so I can fix it right away. And nightly builds are released too frequently to send to BetaNews.

wormeyman wrote:Maybe i like to archive old stuff?


... I knew there're gonna have someone ask for this...

wormeyman wrote:Also when scroll with my mouse it sometimes switches to the next unread page and that gets really annoying how do i turn it off or is this a known bug/feature i'm pretty sure it's a feature i just can't figure out how to turn it off.


you can config mouse wheel sensitivity in GreatNews.ini

[Advanced]
MouseWheelSensitivity=5

bigger number is less sensitive. The default is 5. You can set it to something like 20 to turn it off.

Posted: Thu Jan 26, 2006 8:16 pm
by wormeyman
Clicking open links in external browser crashed great news

Posted: Thu Jan 26, 2006 8:32 pm
by Jack
wormeyman wrote:Clicking open links in external browser crashed great news


hmm, I could reproduce it? Does it happen everytime? If so, can you send me your GreatNews.ini file?

Posted: Thu Jan 26, 2006 11:29 pm
by wormeyman
It only happened when i changed it to external browser because somehow the setting got changed back i can try to reproduce it.

Code: Select all

[Environment]
WinPlacement=2 3 (-1,-1) (-1,-1) (84,109,1143,797)
ChannelTreeClosed=N
ChannelTreePos=268
NewsListClosed=Y
NewsListPos=155
DateFilter=3
StatusFilter=0
CleanupLastRun=2006/01/18 00:38:19
Language=gn_eng.ini
ColWidthTitle=400
ColWidthDate=130
ColWidthAuthor=150
ColWidthChannel=120
NewsListSortColumn=-1
NewsListSortAscending=N

[Options]
Style=Newspaper.css
AutoUpdate=N
CheckNewVersion=Y
RemoveFromTaskBar=Y
AutoUpdateFreq=1
CleanupReminder=2
SecondsToMarkItemRead=2
SecondsToMarkChannelRead=0
MarkChannelReadWhenSwitching=Y
AutoUpdateChannels=Y
StartupScreen=1
UpdateChannelWhenClick=Y
PageSize=10
NextPageOpenUnread=1
MarkReadAutomatically=0
SelectedItemFeatures=177
HighlightNewsWatch=Y
NotifyDinosaurChannels=Y
DinosaurDays=60
NewItemPopupSeconds=60
DoubleClickingNewsList=0
ProxyToUse=0
ProxyServerUrl=
ProxyPort=80
ProxyServerUser=
ProxyServerPassword=
ProxyServerBypass=<local>
CleanupDefault=1
CleanupDeleteUnread=N
CleanupDeleteLabeled=N
CleanupCompress=N
CleanupKeepItems=1
CleanupDeleteTempFiles=N
CleanupNumOfItemsToKeep=50
CloseToTray=N
PodcastingEnclosuresTypes=.mp3;.mp4;.aac;.oog.wmv;.wma;.avi;.wav;.mpeg;.mov;.pdf;

[Usability]
AutoCloseNewsList=N
AutoSetFilterToUnread=N
AutoMarkLastChannelAsRead=Y
SearchAutoOpenNewsList=Y
ShowTooltipAfterUpdate=N
MiddleClickToNewWindow=0
BlockPopups=1
OpenRssLinkInDefaultBrowser=1
DisableTabbedBrowsing=Y
NoAutoGroupCollapsing=N
MouseWheelSensivity=50
[SearchChannelDefinition]
Yahoo! - Company News via RSS=http://finance.yahoo.com/rss/headline?s=%KEYWORD%
Feedster=http://www.feedster.com/search.php?q=%KEYWORD%&sort=date&content=full&type=rss&limit=20
MSN=http://search.msn.com/results.aspx?q=%KEYWORD%&format=rss
Flickr=http://www.flickr.com/services/feeds/photos_public.gne?tags=%KEYWORD%&format=rss_200
Google Blog Search=http://blogsearch.google.com/blogsearch_feeds?q=%KEYWORD%&btnG=Search+Blogs&num=50&output=rss
Google Blog Search By Date=http://blogsearch.google.com/blogsearch_feeds?q=%KEYWORD%&btnG=Search+Blogs&num=50&output=rss&scoring=d
[Statistics]
NumOfChannels=10
ExcludeDisabledChannels=N

Posted: Fri Jan 27, 2006 5:16 am
by Alexander
Is it just me or does that this built drop feed items? It's easy to see what I mean in the following screenshot:

Image

It says 4 unread feed items, but only three are displayed. Never had this problem before this upgrade.

Best,
Alex

Posted: Fri Jan 27, 2006 5:33 am
by Kimi Raikkonen
The right button + wheel to NEXT channel has problems with non read posts.... When I use this and I have a channel with X news.. sometimes some news still unread, but when I'll try to see there are no newa to read.

If I use F8, or click on NEXT, the problem don't apear.

Thanks

Posted: Fri Jan 27, 2006 5:54 am
by Gizmo
Alexander wrote:Is it just me or does that this built drop feed items? It's easy to see what I mean in the following screenshot:


We're already talking about that. Take a look at this thread:
http://www.curiostudio.com/forum/viewtopic.php?t=1026

Posted: Fri Jan 27, 2006 8:01 am
by Guest
Ahh sorry bout that; I only saw the title of your thread and it didn't seem to relate to my problem - thanks for the update.

Posted: Fri Jan 27, 2006 3:53 pm
by wormeyman
I can confirm alex's bug it happens to me as well don't know how to re-produce it yet. I think that leaving a channel will not mark them as read but when you go back to the channel group none will be available to be read.

Posted: Fri Jan 27, 2006 5:53 pm
by Jack
wormeyman wrote:I can confirm alex's bug it happens to me as well don't know how to re-produce it yet. I think that leaving a channel will not mark them as read but when you go back to the channel group none will be available to be read.


It's probably fixed in build 360. Please give it a try